Results 1 to 9 of 9

Thread: Exim/ACL config question

  1. #1
    bdominick's Avatar
    bdominick is offline I am a Glowru!
    Join Date
    Dec 2007
    Posts
    76

    Default Exim/ACL config question

    I have installed ColdFusion MX 7 on my dedicated server, and of course I would like to be able to use CF's built-in email capabilities. In order to do so, I need to set Exim to allow all mail from localhost/127.0.0.1 to relay, to local and remote addresses, no questions asked. I've done this on other mail servers, but I'm not super familiar with Exim, so I'm wondering how to edit the config for this.

    Can I safely add this line to the Exim config...
    host_accept_relay= localhost
    I'm also not exactly sure how the Exim config editor inside WHM works. It seems to have a bunch of blank textareas where new commands can be added?

  2. #2
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,350

    Default

    If you edit the exim.conf file directly, cPanel will overwrite your changes next time it is updated, which is nightly.

    So that would need to be added in the WHM editor which stores the configuration in a DB file which will prevent it from being overwritten.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  3. #3
    bdominick's Avatar
    bdominick is offline I am a Glowru!
    Join Date
    Dec 2007
    Posts
    76

    Default Yeah, but how?

    Okay, I know what I want to alter, but I can't figure out how to do it with WHM's "advanced" exim config editor, which has to be the most cockeyed configuration editor I've ever seen.

    In the uneditable section titled Main Configuration Settings, we find this:

    # The use of your host as a mail relay by any host, including the local host
    # calling its own SMTP port, is locked out by default. If you want to permit
    # relaying from the local host, you should set
    #
    # host_accept_relay = localhost

    In most config editors, I would just remove the # to enable that setting, then I would get on with my day. Not so with this thing. If I try entering that line, without the #, in the very next editable area, the processing page tells me there's a syntax error, and I have to go undo it. So how, practically speaking, does one go about activating a commented-out setting in the exim config editor?

  4. #4
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,350

    Default

    Quote Originally Posted by bdominick View Post
    WHM's "advanced" exim config editor, which has to be the most cockeyed configuration editor I've ever seen
    That's the truth. I have been asking them for years to make something logical and that thing certainly is not.

    What is the name/label of the text area that you are trying to put this in?
    host_accept_relay = localhost
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  5. #5
    bdominick's Avatar
    bdominick is offline I am a Glowru!
    Join Date
    Dec 2007
    Posts
    76

    Default

    The textarea right underneath this inexplicably shameful text

    #!!# These ACLs are crudely constructed from Exim 3 options.
    #!!# They are almost certainly not optimal. You should study
    #!!# them and rewrite as necessary.

    begin acl

    That's the very next place they offer to make any changes. I just stuck the host_accept_relay = localhost line right in there.

    (Really, who would make software that comments on itself, "this is really crappy, you should change it"?)

  6. #6
    bdominick's Avatar
    bdominick is offline I am a Glowru!
    Join Date
    Dec 2007
    Posts
    76

    Default

    Actually, it looks like that line is depricated, according to cPanel Forums

    There's a line that reads:

    hostlist relay_hosts = lsearch;/etc/relayhosts : \
    localhost
    that's supposed to open the relay for the localhost machine. Also on the above page I see advice that the nobody user should be allowed to send mail (in Tweak Settings). I changed that, but still I can't get ColdFusion to relay mail through localhost.

  7. #7
    bdominick's Avatar
    bdominick is offline I am a Glowru!
    Join Date
    Dec 2007
    Posts
    76

    Default

    I've narrowed this down to being a ColdFusion problem. I set up a PHP app that uses localhost relay, and it worked fine. The ColdFusion Administrator UI has a way to test connections, and it didn't work. I can telnet to localhost port 25 as root on my server. Not really sure why CF can't seem to connect to it... Anyway, I'm seeking a solution in CF circles, rather than here. Thanks.

  8. #8
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,350

    Default

    Quote Originally Posted by bdominick View Post
    (Really, who would make software that comments on itself, "this is really crappy, you should change it"?)
    Heh, pretty much every piece of open source has something like that in there. One programmer thinks an older programmer did something wrong, comments it for later improvement, and it either gets deprecated or fixed

    If you find out what it is we'd be interested in hearing the solution. if you still cannot figure it out after some research, set us up some example and we can possible get someone from cPanel iin there for suggestions.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  9. #9
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,350

    Default

    One thing you might keep in mind is that you are going to need to have a valid email address on the server to send the email from. So, make an account in cPanel for whatever address you want to send email from. Then go into the CF admin and configure it to use that address for outgoing email.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16