Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [PHPMotion] Failed to find flength file

  1. #1
    Alexander's Avatar
    Alexander is offline Technical Analyst
    Join Date
    Jul 2007
    Posts
    1,349

    Lightbulb [PHPMotion] Failed to find flength file

    What this solution fixes:
    1) Progress bar on uploading is not showing
    2) You are getting an error when uploading "Failed to find flength file"


    Please, make sure that your custom php.ini contains the following:
    Code:
    upload_max_filesize = 100M
    post_max_size = 100M
    output_buffering = On
    max_execution_time = 1000
    max_input_time = 1000
    session.gc_maxlifetime = 14400
    enable_dl = on
    And .htaccess:
    Code:
    SecFilterEngine Off
    SecFilterScanPOST Off


    Related Articles:

    http://forums.glowhost.com/showthread.php?t=2589
    http://forums.glowhost.com/showthread.php?t=2590
    Last edited by Matt; 03-04-2011 at 04:20 PM.

  2. #2
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    Please note that adding this to your .htaccess:
    Code:
    SecFilterEngine Off
    SecFilterScanPOST Off
    Will disable mod security on your website. Mod security can help prevent many types of common hacks, but sometimes can produce false positives especially on sites that allow public uploading.
    Last edited by Matt; 03-04-2011 at 03:48 PM.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  3. #3
    cornnfedd is offline Working on Master Status
    Join Date
    Dec 2007
    Posts
    78

    Default

    where do i put the php.ini file?

  4. #4
    cornnfedd is offline Working on Master Status
    Join Date
    Dec 2007
    Posts
    78

    Default

    Quote Originally Posted by Matt View Post
    Please note that adding:
    Code:
    SecFilterEngine Off
    SecFilterScanPOST Off
    Will disable mod security on your website. Mod security can help prevent many types of common hacks, but sometimes can produce false positives especially on sites that allow public uploading.
    can you tell me more about this?

    is there any other way of fixing this bug without doing this?

  5. #5
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    Quote Originally Posted by cornnfedd View Post
    where do i put the php.ini file?
    In the directory where the script is installed, as well as in the admin directory. Though a cleaner way is to just stick it in the top level directory of your script (usually public_html) and then set it up so that the one file is read recursively from the top all the way down to all subfolders. Check this thread for how to do that:

    http://forums.glowhost.com/showthread.php?t=2581
    Last edited by Matt; 03-04-2011 at 04:21 PM.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  6. #6
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    Quote Originally Posted by cornnfedd View Post
    is there any other way of fixing this bug without doing this?
    I don't think it is a bug. This:

    Code:
    upload_max_filesize 100M
    post_max_size = 100M
    output_buffering = On
    max_execution_time = 1000
    max_input_time = 1000
    session.gc_maxlifetime = 14400
    last I checked on their installation docs was required to be in PHP in order for the script to run.

    The mod security thing is if you are getting 406 errors on the site, it will get rid of them and it will also disable mod security completely on the account.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  7. #7
    cornnfedd is offline Working on Master Status
    Join Date
    Dec 2007
    Posts
    78

    Default

    i changed the .htaccess file as per above but not the other bit and it all seems to work fine, but i dont want to leave my site susceptible to hackers, so am i ok or not?

    thanks.

  8. #8
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    Mod security protects against known exploits, which means basically it helps prevent hacks on sites where the site owner is lazy and misses an update or two to the software they run. You should be safe without it, so long as you update your scripts the same day new security releases have been released.

    If you never update your scripts, mod security will help, but it won't get them all.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  9. #9
    kyleglow You Are Posting As A Guest - Please Register or Log In

    Default (script conflict) Modified cgi-bin/uu_default_config.pm

    Ive modified /home/user/www/cgi-bin/uu_default_config.pm to solve a conflict with the upload file size in the php.ini file

    If you have 300 meg in your php.ini for upload_max_filesize and post_max_size like so:

    Code:
    upload_max_filesize 300M
    post_max_size = 300M
    Then you are also going to have to reconfigure the maximum allowed bytes in the uu_default_config.pm to be at least the same as your php.ini.

    FROM:
    Code:
    max_upload => 209715200,
    TO
    Code:
    max_upload => 314572800,
    314572800 bytes is equal to 300 megabytes.
    Last edited by Matt; 07-17-2008 at 01:16 PM. Reason: clarification.

  10. #10
    Neron is offline Newbie
    Join Date
    Mar 2009
    Posts
    1

    Default

    Hi, I have the same problem on my account. Defoult I did't have any php.ini file in my home folder or in the folder where phpmotion is installed. When i add a php.ini file with

    upload_max_filesize 100M
    post_max_size = 100M
    output_buffering = On
    max_execution_time = 1000
    max_input_time = 1000
    session.gc_maxlifetime = 14400

    after that new error take place "extension_dir does not exists /usr/php4/lib/php/extensions/no-debug-non-zts-20020429". I noticed that there is another post about this error but i didn't find a solution there. I'am playing with it for 2 days now, please help, what I doing wrong ?

Page 1 of 2 12 LastLast

LinkBacks (?)

  1. Error
    Refback This thread
    05-29-2009, 03:20 AM
  2. 05-18-2009, 07:10 AM
  3. 05-09-2009, 05:01 AM
  4. Error
    Refback This thread
    05-02-2009, 06:38 PM
  5. 04-08-2009, 10:22 AM
  6. 03-19-2009, 08:38 AM
  7. 07-28-2008, 11:16 PM
  8. 05-28-2008, 06:26 PM

Similar Threads

  1. [PHPMotion] Change the player logo for PHPmotion
    By Matt in forum Knowledge Base
    Replies: 1
    Last Post: 03-12-2011, 07:49 AM
  2. [ERROR] Clipshare Failed to find flength file
    By Matt in forum Knowledge Base
    Replies: 0
    Last Post: 09-06-2008, 01:14 PM
  3. Where do I find all my site bonuses?
    By Matt in forum Knowledge Base
    Replies: 2
    Last Post: 03-03-2006, 12:04 AM
  4. [Domains] Failed Domain transfer to InstaPro.net
    By Matt in forum Knowledge Base
    Replies: 0
    Last Post: 01-18-2005, 03:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16