Results 1 to 5 of 5

Thread: Installing Pear Packages from Cpanel

  1. #1
    charlesh's Avatar
    charlesh is offline Master Glow Jedi
    Join Date
    Aug 2006
    Location
    Atlanta, GA - better than you imagined it would be.
    Posts
    189

    Default Installing Pear Packages from Cpanel

    I need to install quickform2 for a client site and when I go to install it, I get a message saying that it is dependent upon html_common package. I went to install common2, the php5 version of that, and it gives me the following in the cpanel output window:

    Code:
    Warning: popen() has been disabled for security reasons in Guess.php on line 247PHP 
    Warning:  popen() has been disabled for security reasons 
    in /usr/local/lib/php/OS/Guess.php on line 247Warning: popen() has been disabled for 
    security reasons in /usr/local/lib/php/OS/Guess.php on line 247Warning: fgets(): supplied
     argument is not a valid stream resource in Guess.php on line 248PHP Warning:  fgets(): 
    supplied argument is not a valid stream resource in /usr/local/lib/php/OS/Guess.php on 
    line 248Warning: fgets(): supplied argument is not a valid stream resource 
    in /usr/local/lib/php/OS/Guess.php on line 248Warning: pclose(): supplied argument is not 
    a valid stream resource in Guess.php on line 256PHP Warning:  pclose(): supplied 
    argument is not a valid stream resource in /usr/local/lib/php/OS/Guess.php on line 
    256Warning: pclose(): supplied argument is not a valid stream resource 
    in /usr/local/lib/php/OS/Guess.php on line 256pear/HTML_Common2 requires PHP (version 
    >= 5.1.4), installed version is 4.4.7No valid packages foundinstall 
    failed/usr/bin:/bin:/sbin:/usr/sbin:/usr/bin:/bin:/usr/local/bin
    I guess that I could
    manually install it, but figured I must be doing something wrong. Does anyone have any sucess with installing Pear packages from Cpanel?Thanks,
    charlesh
    Last edited by charlesh; 01-06-2008 at 10:30 AM.

  2. #2
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    Are you doing this from a specific user's cPanel or from WHM or the CLI?
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  3. #3
    charlesh's Avatar
    charlesh is offline Master Glow Jedi
    Join Date
    Aug 2006
    Location
    Atlanta, GA - better than you imagined it would be.
    Posts
    189

    Default

    Matt,

    Thanks for the quick reply. I first tried it logged in as root from WHM to the user's control panel, then next I tried it as the user logged into the control Panel. Both had the same result.

    Thanks,
    Charles

  4. #4
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,250

    Default

    The problem is both of those libs are in beta right now and cannot be installed on a shared server. VPS or dedicated perhaps but it would be at your own risk. Sorry.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  5. #5
    charlesh's Avatar
    charlesh is offline Master Glow Jedi
    Join Date
    Aug 2006
    Location
    Atlanta, GA - better than you imagined it would be.
    Posts
    189

    Default

    Hmmm. OK. It will be this year, hopefully that I'll go dedicated or VPS. I just wanted the php5 versions, but the old one should work just fine with what I'm doing.

    Thanks again,
    CharlesH

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16