Results 1 to 6 of 6

Thread: [Error] Error Code 500- Internal Server Error

  1. #1
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    4,217

    Default [Error] Error Code 500- Internal Server Error

    Page throwing a 500 Internal Server Error?

    Here are some things you can do to help troubleshoot the errors.

    For Perl Scripts:
    After you are positive that you have uploaded your CGI scripts in ascii mode and have set the permissions correctly (usually 755)?

    If yes, you might consider adding a "- w" after the shebang line (#!/usr/bin/perl)

    Your shebang will then look like this:

    Code:
    #!/usr/bin/perl -w
    This will sometimes cause Perl to spit out exactly what the issue is.

    For PHP Scripts:
    After you are positive that you have uploaded your PHP scripts in binary mode and have set the permissions correctly (usually 644 or 444)?

    View the error logs!

    Did you know that your control panel has error logging enabled?

    This lets you see where the script might be failing as well.

    Log into the control panel and select Stats > Error Log.

    You might even see "error_log" in the same directory that your scripts run in. This can be a good place to start.
    Last edited by Matt; 09-06-2010 at 12:08 PM.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  2. #2
    Manna8's Avatar
    Manna8 is offline Junior Web Sage
    Join Date
    Mar 2007
    Posts
    13

    Default

    Hi Matt

    My sites gone off the air with the error message below... I have been trying to install amember as we are having our site built (very different to the site we have now which is a tester site for us to try things out on)
    Amember requires us to upload in Binary which I did however and recieved the error message. I have contacted them and their response was that php is not enabled on our host - which I have gone back to them saying it is. However, in the meantime I have read your above and I'm a bit confused. Amember require the CHMOD to be set to either 777 770 or 707 which again I had done, and still the message. Can you help me work out what the problem is? I am still waiting for amember to get back to me regarding php being enabled, but perhaps you might have something I can tell them to help sort this out. I have also noticed Haylee's SSL certificate has expired?

    Kind regards
    Caroline Connor
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, webmaster@domain.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at www.domain.com Port 80
    Last edited by Matt; 05-08-2007 at 09:44 AM. Reason: To clarify a bit more and add some things

  3. #3
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    4,217

    Default

    Have you tried chmod 755 or 644? Anything higher than that will not run on servers that use PHP CGI. (Also known as php suexec or suphp) So if the vendor says to use 777 use 755 (on directories) and 644 on php files.

    What does the error log in cPanel say?
    Last edited by Matt; 05-07-2007 at 10:28 AM.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  4. #4
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    4,217

    Default

    Also check out if your .htaccess file has 'php_value' or 'php_flag' in it. I think amember uses those and that is the incorrect syntax for PHP CGI.

    See this thread if you see php_flag or php_value errors in your error log:
    http://glowhost.com/forums/showthread.php?t=373
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  5. #5
    Manna8's Avatar
    Manna8 is offline Junior Web Sage
    Join Date
    Mar 2007
    Posts
    13

    Default

    Thanks Matt!

  6. #6
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    4,217

    Default

    No problemo. Sorry for the late response I never saw you replied
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

Similar Threads

  1. ffmpeg.so error
    By Scott in forum General Support
    Replies: 1
    Last Post: 06-01-2009, 08:36 AM
  2. cP Backup Error
    By bdominick in forum WHM, Resellers, VPS and Dedicated Hosting Topics
    Replies: 1
    Last Post: 05-28-2009, 12:10 PM
  3. Replies: 0
    Last Post: 03-29-2008, 10:31 AM
  4. Replies: 0
    Last Post: 10-23-2007, 03:10 PM
  5. Internal server error
    By andychev in forum General Support
    Replies: 3
    Last Post: 03-25-2007, 05:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17