Results 1 to 4 of 4

Thread: extension_dir does not exists /usr/local/bin/php

  1. #1
    trondsbr is offline Almost no longer a newbie!
    Join Date
    Mar 2008
    Location
    Mandan, ND
    Posts
    4

    Default extension_dir does not exists /usr/local/bin/php

    I have phpmotion installed. I cannot upload due to this error.
    ERROR: Failed to find flength file

    I searched the phpmotion forum and did the fix for the php.ini
    upload_max_filesize = 100M
    post_max_size = 100M
    output_buffering = on
    max_execution_time = 1000
    max_input_time = 1000
    session.gc_maxlifetime = 14400

    RewriteEngine On


    # Turn off mod_security filtering.
    SecFilterEngine Off

    # The below probably isn't needed,
    # but better safe than sorry.
    SecFilterScanPOST Off

    This error now occurs
    extension_dir does not exists /usr/lib/php/extensions/no-debug-non-zts-20060613

    I know the path to php is /usr/local/bin/php so I added this to the php.ini file
    extension_dir = "/usr/local/bin/php/"

    No luck so I tried variations like this all without luck.
    extension_dir = "/usr/local/bin/php
    /extensions/no-debug-non-zts-20060613"
    extension_dir = "/usr/local/bin/php/modules"
    extension_dir = "/usr/local/bin/php/extensions"

    I am stuck. Without the extension_dir in the php.ini the site displays fine, the uploads don't work.

    Hopefully someone else with phpmotion has been through this and knows a fix for me.

    Thanks, Brian

  2. #2
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,256

    Default

    When you say they don't work, can you elaborate on that? Have you tried a very small file? Did you look at your CGI scripts for that script? Sometimes they need to be configured too. And they definitely need to be in your cgi-bin.

    You should not need to define an extension_dir. That is for the phpshield loaders and they are already included in the main PHP configuration.

    You are also going to want to make sure your paths and settings are properly configured in your config.php file:

    http://glowhost.com/forums/knowledge...ings-1091.html
    Last edited by Matt; 03-20-2008 at 12:10 AM.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

  3. #3
    trondsbr is offline Almost no longer a newbie!
    Join Date
    Mar 2008
    Location
    Mandan, ND
    Posts
    4

    Default

    Thanks for the fast reply Matt. I did some more in-depth looking and seem to have found how to fix it.

    The error ERROR: Failed to find flength file according to the phpmotion forum is due to php configurations. With GlowHost this is not the case. The only thing you must make certain to check is the permissions of the files and folders along with the cgi-bin file editing. When I left them at 755 it caused errors. Change them to the following and it was resolved.
    1. CHMOD all the following files and directories to 777
      • /setup
      • /pictures
      • /classes
      • /temp
      • /logs
      • /addons
      • /uploads
      • /uploads/avi
      • /uploads/thumbs
      • /uploads/audio
      • /uploads/audio/temp
      • /uploads/pictures
    2. CHMOD all the following files and directories to 755
      • /cgi-bin/all files in there
      • /cgi-bin/audio/all files in there

    Also, for anyone that may be doing a search. I ran into this as well.

    To increase the maximum allowed file size for upload.
    1) Edit the file cgi-bin/uu_default_config.pm
    max_upload => 20971520
    This figure is in bytes = 20MB, to change to say 200MB just add a "zero" etc.

  4. #4
    Matt's Avatar
    Matt is offline GlowHost Administrator
    Join Date
    Jan 2005
    Location
    Behind your monitor
    Posts
    5,256

    Default

    Well I think changing the directories to 777 might work the .php files in those dirs probably will not run at anything higher than 644 due to the suPHP restrictions built into our PHP. So if you get Internal Server Errors on your PHP files set to 777, that is why.

    And yes, your cgi and all files in the cgi bin do need to be at 755.
    Send your friends and site visitors to GlowHost and get $125 plus bonus!
    GlowHost Affiliate Program | Read our Blog | GlowHost's Facebook | Follow us on Twitter | GlowHost on Google+

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16