Results 1 to 9 of 9

Thread: Drupal Crash . . .

  1. #1
    JohnMorris is offline Certified Glow Sage
    Join Date
    Oct 2007
    Posts
    32

    Default Drupal Crash . . .

    Hi,

    I have been successfully using Drupal for a few weeks with a small number of users. Only glitch is there isn't enough memory to run the colour changer dialogue for one of the default themes. Also successfully added the FCK editor module.

    However, today I added the Panels and Views modules. Then logged in as admin and enabled them in the modules control panel. I then got the following, which I don't know how to clear or fix. Any ideas??? Thanks!

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 142384 bytes) in /home/personal/public_html/standupsales.com/drupal/includes/database.inc on line 199

    Warning: Table 'watchdog' was not locked with LOCK TABLES query: INSERT INTO watchdog (uid, type, message, severity, link, location, referer, hostname, timestamp) VALUES (1, 'php', '<em>Table &amp;#039;sessions&amp;#039; was not locked with LOCK TABLES\nquery: SELECT sid FROM sessions WHERE sid = &amp;#039;19cecee7b7b8f30c8da0487dd6628b96&amp;#03 9;</em> in <em>/home/personal/public_html/standupsales.com/drupal/includes/database.mysql.inc</em> on line <em>172</em>.', 2, '', 'http://standupsales.com/drupal/', 'http://www.standupsales.com/', '64.231.255.26', 1195787482) in /home/personal/public_html/standupsales.com/drupal/includes/database.mysql.inc on line 172

    Warning: Table 'watchdog' was not locked with LOCK TABLES query: INSERT INTO watchdog (uid, type, message, severity, link, location, referer, hostname, timestamp) VALUES (1, 'php', '<em>Table &amp;#039;sessions&amp;#039; was not locked with LOCK TABLES\nquery: INSERT INTO sessions (sid, uid, cache, hostname, session, timestamp) VALUES (&amp;#039;19cecee7b7b8f30c8da0487dd6628b96&amp;#0 39;, 1, 0, &amp;#039;64.231.255.26&amp;#039;, &amp;#039;form|a:1:{s:32:\\&amp;quot;10a52846e870d ff6c442826552314677\\&amp;quot;;a:2:{s:9:\\&amp;qu ot;timestamp\\&amp;quot;;i:1195787359;s:4:\\&amp;q uot;args\\&amp;quot;;a:1:{i:0;s:14:\\&amp;quot;sys tem_modules\\&amp;quot;;}}}messages|a:1:{s:6:\\&am p;quot;status\\&amp;quot;;a:2:{i:0;s:16:\\&amp;quo t;Installing views\\&amp;quot;;i:1;s:43:\\&amp;quot;Views module installed tables successfully.\\&amp;quot;;}}&amp;#039;, 1195787482)</em> in <em>/home/personal/public_h in /home/personal/public_html/standupsales.com/drupal/includes/database.mysql.inc on line 172

  2. #2
    sergey is offline Master Glow Jedi
    Join Date
    Aug 2005
    Posts
    472

    Default

    This should be corrected and this error shouldn't be shown again. If this issue still persist, please submit a trouble ticket and we will check it from our end.

  3. #3
    JohnMorris is offline Certified Glow Sage
    Join Date
    Oct 2007
    Posts
    32

    Default It works . . .

    Thanks ... I'm just curious ... is it something I need to do in cPanel?

    John

  4. #4
    Alexander's Avatar
    Alexander is offline Technical Analyst
    Join Date
    Jul 2007
    Posts
    1,371

    Default

    This is PHP configuration issue, not Cpanel.

  5. #5
    JohnMorris is offline Certified Glow Sage
    Join Date
    Oct 2007
    Posts
    32

    Default

    What please was the PHP configuration issue? Does your fix apply to my other domains under the same account? I'd just like to know what to ask for in the future...thanks.

  6. #6
    andychev's Avatar
    andychev is offline Master Glow Jedi
    Join Date
    Apr 2005
    Location
    Chester, UK
    Posts
    150

    Default

    I belive the setting in question is the memory limit (set in php.ini) as default this is set to 8mb.

    I had a similar problem with a script and had to increase the memory allocation.

    you can use ini_set so:

    string ini_set ( string $varname, string $newvalue )

    so in the file that is causing problems you would add:

    ini_set("memory_limit","64M"); or whatever memory limit gets it working.

    at the top.

    **HOWEVER** check with glowhost first before you do this i dont know whether this will cause problems in a shared hosting environment.

    Im guessing glowhost will have altered a the php.ini and increased the memory limit so you shouldnt have to use the above. THe change will be server wide.
    Last edited by andychev; 11-24-2007 at 10:40 AM.

  7. #7
    jmarcv's Avatar
    jmarcv is offline Cranky Coder
    Join Date
    Jan 2005
    Posts
    354

    Default

    Andychev! 64MB? If a program needs that much RAM, it belongs on a windows server, not linux! LOL!

  8. #8
    andychev's Avatar
    andychev is offline Master Glow Jedi
    Join Date
    Apr 2005
    Location
    Chester, UK
    Posts
    150

    Default

    Quote Originally Posted by jmarcv View Post
    Andychev! 64MB? If a program needs that much RAM, it belongs on a windows server, not linux! LOL!
    Hmm, I did just kinda pluck that number out of the air when i added it to ensure the program ran reliably. Just tried reducing it and anything under 18mb causes issues.

    It is quite a big program, well sort of! It is a small script to backup and e-mail a complete database backup every few hours via a cron. The database can be anything upto 10mb hence im guessing the size of the database is what is actually causing the issues!

  9. #9
    jmarcv's Avatar
    jmarcv is offline Cranky Coder
    Join Date
    Jan 2005
    Posts
    354

    Default

    That makes sense then. A 10MB DB file will expand a bit when it is turned intro text and then 'mimed' by mail I suppose.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16